Steve Kemp's Blog Writings relating to Debian & Free Software

So I have a new desktop..

Sat, 29 Jun 2013 12:32:38 GMT

So I have a new desktop computer. I installed Wheezy on it via a USB stick, and everything worked. All the hardware. Yay. I guess we take it for granted when things like sound, disks, and network cards just work these days. I remmeber fighting with distros in the past, where such things were not necessarily straightforward.

The only minor complication is the graphics card. I bought a cheap/random GeForce card for the new machine (£30):

$ lspci -nn | grep VGA
01:00.0 VGA compatible controller [0300]: NVIDIA Corporation GF119 [GeForce GT 610] [10de:104a] (rev a1)

Booting up I get a working X.org and GNOME 3.x, but the open graphics driver is "too bad" so I get fallback GNOME; with "Applications" & "Places" menus.

Installing the proprietry driver gave me a full GNOME 3.x experience. But I didn't like it so for the moment I'm running:

  • GNOME fallback mode.
  • Bluetile.
  • Open (nvidia) drivers only.

The plan was to install awesome, or similar, but I'm just a creature of habit and I'm still cloning git/mercurial repos and selectively restoring backups.

My old desktop has been given to my partner to replace the EeeeeePC she's been using for the past year.

I'll fettle over the weekend until I'm back up and running properly; but for the moment I'm good. All my videos/music are ported across. I can print, and I have access to the repos I'm currently working on. (Mostly lumail which will have a new release over the weekend.)

| 4 comments.

 

Comments On This Entry

[gravitar] Anonymous

Submitted at 19:22:48 on 29 June 2013

If you're building a new desktop, why put in an add-in card from the one of the three graphics vendors least compatible with Open Source? For that same £30 you could have upgraded to a system board that included integrated graphics, which would work far better.

[gravitar] Steve Kemp

Submitted at 15:25:26 on 30 June 2013

I'm a pragmatist. My software is almost entirely released under a free license, usually the GPL, but hardware? I'll buy whatever is cheap/available/suitable.

Still, each to their own. If you want to buy only free hardware, with open-source BIOS, firmware, and all that good stuff I wish you luck.

[gravitar] ChrisK

Submitted at 16:06:13 on 30 June 2013

I just built a PC for my father, and used exactly the same Nvidia GT 610 card you chose -- the 'lspci -nn' line is identical, including the "(rev a1)" part. However, I'm having a different experience because I'm using KDE4 rather than Gnome 3.x. In KDE4 using the stock Nouveau drivers, many of the 3D OpenGL features work.

Additionally many of the compositing features work, but a few don't; KDE4 reports that:

"KWin Window Manager
The following desktop effects could not be activated:

o Blur
o Cover Switch
o Startup Feedback"

So from this I gather that the Nouveau driver supports some OpenGL features, but not all of them -- so that's what I think is going on when it comes to your experience with Gnome 3.x going to fallback mode.

For now I'm trying to stick with the Nouvau driver to see whether my dad will be happy with it -- on other systems I use the proprietary Nvidia driver. One of the features you might look into with the proprietary driver is underclocking the videocard for thermal/reliability reasons. For instance on my laptop I use this in my xorg.conf file:

Section "Device"
Driver "nvidia"
Option "NoLogo" "1"
# Following option sets max power saving on both Battery and AC
Option "RegistryDwords" "PowerMizerEnable=0x1; PerfLevelSrc=0x2222; PowerMizerDefault=0x3; PowerMizerDefaultAC=0x3"
VendorName "NVIDIA Corporation"
BoardName "Quadro FX 570M"
BusID "PCI:1:0:0"
EndSection

@Anonymous:
Using a videocard built into the motherboard means you can never upgrade it, and it's typically something I and others want to upgrade. Additionally (and ironically), RMS himself suggests using an Nvidia card because the Nouveau drivers are the most open.

[gravitar] Graham

Submitted at 06:03:43 on 1 July 2013

Nouveau works just fine in both KDE and GNOME with full desktop effects activated. I see two possible causes for the problem.

The first possibility is that the 610 (aka 520) is simply too weak, and the proprietary drivers can make better use of its dismal power.

The second, and IMO more likely, possibility is that the drivers are simply too old. My 560 doesn't work on Wheezy, but works on pretty much any distro that is using kernel version 3.4 or later.

You could try the latest stable Fedora (either 18 or 19, due to be released in the next couple of days), as they have a couple of Nouveau developers on staff and in general are much more up-to-date than Debian, even Sid. Alternatively, you could try a newer kernel on Wheezy; Liquorix makes Nouveau work on my 560 in Wheezy, for example. Or just upgrade to Jessie.

 

Comments are closed on posts which are more than ten days old.

Spiral Logo

Search

Recent Posts

Recent Tags

Links

RSS Feed

  • Subscribe to feed